Jump to content
Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
MaxN68

Open Ardbir - Software Di Controllo Per Sistemi A Pentola Singola(Braumeister Clone)

Recommended Posts

Ah, devo alimentare una elettrovalvola 220v

Non conosco la scheda, comunque da dove prendi i 230V per alimentare l' elettrovalvola?

Prova a prenderla lontano dal traformatore che alimenta la scheda.

 

Inviato dal mio Jolla utilizzando Tapatalk

Share this post


Link to post
Share on other sites

Non vorrei dire una cavolata ma... ho la stessa scheda (nel cassetto) e i relè lavorano a 5v e se ricordo bene la scheda ne eroga 12v...

 

Inviato dal mio GT-I9505 utilizzando Tapatalk

Share this post


Link to post
Share on other sites

Intendevo dire che la scheda ardbir eroga 12v e i relè sulla schedina lavorano a 5v.

Però non credo sia questo il problema perché se hai realizzato il sistema proposto da sgabuzen la tensione è giusta.

Prova a schermare l' elettromagnetismo generato dalla bobina dell' elettrovalvola.

 

 

Inviato dal mio GT-I9505 utilizzando Tapatalk

Share this post


Link to post
Share on other sites

L'elettrovalvola è distante.

Arduino lavora a 5v!

Accetta alimentazione da 7 a 12 volt

Share this post


Link to post
Share on other sites

Io ho avuto lo stesso problema con il display, alla fine si è spento ed è morto, mai più acceso.

Per i disturbi dovuti alle bobine, aggiungi condensatori in parallelo all'alimentazione di arduino, più grandi che puoi, è l'unico modo per ammortizzare i picchi dovuti ai carichi induttivi. Io ho risolto così.

Share this post


Link to post
Share on other sites

Con Arduino sono ben noti alcuni problemi di elettromagnetismo indotto che riescono a superare le protezioni dei moduli relè, sono stati notati anche fenomeni riguardanti l'uso degli interrupts che captano i cambiamenti di stato elettromagnetico e arrivano a bloccare Arduino stesso.

 

La scheda ArdBir lavora a 12V.
Gli output sono gestiti appositamente con dei transistor.

Share this post


Link to post
Share on other sites

Non sono la persona più indicata per l'hardware (io ho sviluppato solo la parte software).
Intanto di direi di usare lo schema ArdBir e non altri schemi e di usare al posto del relè standard un ssr.
 

Share this post


Link to post
Share on other sites

Ok. Venerdì mi arriva il cambio del.modulo relè è vedo se va. In caso compro uno allo stato solido.

Lo schema è quello di sgabuzen.

Share this post


Link to post
Share on other sites

Non conosco quello schema e se sono stati esclusi/cambiati dei componenti dallo schema originale ArdBir.
 

Share this post


Link to post
Share on other sites

Io ho avuto lo stesso problema con il display, alla fine si è spento ed è morto, mai più acceso.

Per i disturbi dovuti alle bobine, aggiungi condensatori in parallelo all'alimentazione di arduino, più grandi che puoi, è l'unico modo per ammortizzare i picchi dovuti ai carichi induttivi. Io ho risolto così.

Hai aggiunto condensatori in parallelo all'alimentazione del display (che proviene dai pin di Arduino) oppure sull'alimentazione di Arduino (7-12V)?

Share this post


Link to post
Share on other sites

Il circuito filtro fatto coi condensatori va calcolato

Share this post


Link to post
Share on other sites

Ho montato la scheda come sul.sito di sgabuzen.

 

Scusa a quale scheda ti riferischi posta foto ?

 

L' Amico Giovanni in arte sgabuzen tempo fa ha fatto un video per far vedere

come si poteva usare ArdBir anche senza il PCB ma questo ha creato un po di confusione

 

Perche quello proposto va bene per prove e test a banco ma in alcune situazioni di produzione NON va bene

Giovanni ha fatto quel articolo perche molti ci e gli chiedevano info sul PCB e Schede

e le riposte erano tarde dato che avevamo finito tutte le scorte

 

Oggi siamo dinuovo allineati e comunque per chi sa fare ci sono sempre gli schemi e files

per farsi in casa il PCB Ufficiale di ArdBir

 

Che VI ricordo ha una serie di componenti attivi e passivi e spessore delle piste PCB

che aiuta ad avere una soluzione stabile che spesso con un collegamento volante tipo quello della BredBoard

volante proposto in quel video non è affidabile e crea problemi tipo quello che citate

  • Like 1

Share this post


Link to post
Share on other sites

Ok. Quindi se mi rifaccio da me.la pcb dovrei superare questo.problema?

Oppure devo.per forza farmi.fare.la scheda stampata?

Share this post


Link to post
Share on other sites

Se ti fai il PCB come in allegato al software avrai migliore stabilità  e gestioni ma se il problema è dii tipo elettromagnetico (bobina elettrovalvola) dubito che risolva.

Fai un test allontanando il più possibile l'elettrovalvola parlo di un metro o più...

Ti consiglio comunque di farti il PCB.

 

Inviato dal mio GT-I9505 utilizzando Tapatalk

Share this post


Link to post
Share on other sites

Ok. Quindi se mi rifaccio da me.la pcb dovrei superare questo.problema?

 

Usare il PCB Ufficiale o Stampato da Service o Da te se fatto bene funziona :D

 

Allora non è detto che risolvi il problema ma almeno parti da un punto sicuro.

 

Ovvero sai che lato PCB Elettronica a Monte sei OK

Dato che usi una configurazione già  collaudata ormai da anni e da svariate persone

Poi questo non esclude come ti dicono anche altri utenti in forum che potresti avere anche

altre anomalie problemi a valle

 

Ma almeno parti da una situazione piu sicura e già  testata :D

 

Cosi come sei ora non sai se è un prob d'elettronica o di altro

e la ricerca guasto è molto più complessa e laboriosa

Edited by saviothecnic

Share this post


Link to post
Share on other sites

Fatto ik test e non è andato bene.

La.pcb penso di realizzarla.su millefori.

Ho già  fatto cose simili(una radiotrasmittente) però seguendo uno schema.

 

Su mille fori va bene?

Il problema è trovare una azienda che faccia una pcb. Non è conosco neanche una in città 

Share this post


Link to post
Share on other sites

Il problema è legato al display. Verificare connessioni / saldature

 

Inviato dal mio SM-N9005 utilizzando Tapatalk

Share this post


Link to post
Share on other sites

Con il 1000fori ti esce una cosa "bruttina" cerca nel forum magari trovi una pcb già  fatta. Oppure trovi chi te la fa non so qui ma su ebay ci sono.

 

Inviato dal mio GT-I9505 utilizzando Tapatalk

Share this post


Link to post
Share on other sites

Hai aggiunto condensatori in parallelo all'alimentazione del display (che proviene dai pin di Arduino) oppure sull'alimentazione di Arduino (7-12V)?

 

Io non ho una scheda arduino, me lo sono costruito partendo dal controllore e i quarzi, saldando su millefori.

E' proprio l'atmega ad essere sensibile a picchi sull'alimentazione.

I condensatori conviene distribuirli su tutte le linee di alimentazione, e devono essere di capacità  elevata, devono solo fare da tampone.

Io i primi test li avevo fatti collegando alla scheda una stazione saldante munita di dimmer, durante le commutazioni riusciva addirittura a resettarmi il controllore facendo ripartire il programma.

Dopo aver inserito qualche condensatore, saldati brutalmente sulle piste nel retro della scheda, ho risolto ogni problema.

  • Like 1

Share this post


Link to post
Share on other sites

Con il 1000fori ti esce una cosa "bruttina" cerca nel forum magari trovi una pcb già  fatta. Oppure trovi chi te la fa non so qui ma su ebay ci sono.

 

Inviato dal mio GT-I9505 utilizzando Tapatalk

 

Può venire bruttina, dipende da quanto lavori pulito, e sicuramente a livello estetico non regge il confronto con il pcb fotoinciso, però tanto alla fine va chiuso in scatola, e non lo vedi più.

Questo è il mio, ed è fatto su millefori :

 

https://www.youtube.com/watch?v=aE7xnj4zsmA

Share this post


Link to post
Share on other sites

Thor, quanti condensatori metteresti e dove? Avrei la.possibilita di metterli e vorrei crearla stabile. Il problema può essere anche quello

Share this post


Link to post
Share on other sites

La scheda Arduino monta già  u condensatori sulla linea vcc. Sulle versione standalone è obbligatorio mettere le capacità  da 100nF (da capire che valore avevi previsto sul tuo circuito). Certo non abbiamo una foto del sistema ..... quello che suggerisco è di verificare le saldature del display.

 

Inviato dal mio SM-N9005 utilizzando Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×